지식공유2018. 11. 6. 19:38




centos 7.5 - nvidia driver 410 설치시 Dependency error 발생



<problem>


[root@dasandata:~]# 

[root@dasandata:~]# curl  -L -o  cuda-repo-rhel7-8.0.61-1.x86_64.rpm \

>  http://developer.download.nvidia.com/compute/cuda/repos/rhel7/x86_64/cuda-repo-rhel7-8.0.61-1.x86_64.rpm


[root@dasandata:~]# yum -y install cuda-repo-rhel7-8.0.61-1.x86_64.rpm

[root@dasandata:~]# 

[root@dasandata:~]# cat $/etc/yum.repos.d/cuda.repo

[cuda]

name=cuda

baseurl=http://developer.download.nvidia.com/compute/cuda/repos/rhel7/x86_64

enabled=1

gpgcheck=1

gpgkey=http://developer.download.nvidia.com/compute/cuda/repos/rhel7/x86_64/7fa2af80.pub

[root@dasandata:~]# 

[root@dasandata:~]# 

[root@dasandata:~]# 

[root@dasandata:~]# yum -y install cuda-9-0


--> Finished Dependency Resolution

Error: Package: 3:nvidia-driver-libs-410.72-1.el7.x86_64 (cuda)

           Requires: libglvnd-gles(x86-64) >= 0.2

Error: Package: 3:nvidia-driver-libs-410.72-1.el7.x86_64 (cuda)

           Requires: libglvnd-egl(x86-64) >= 0.2

Error: Package: 3:nvidia-driver-libs-410.72-1.el7.x86_64 (cuda)

           Requires: libglvnd-opengl(x86-64) >= 0.2

Error: Package: 3:nvidia-driver-libs-410.72-1.el7.x86_64 (cuda)

           Requires: libglvnd-glx(x86-64) >= 0.2

Error: Package: 3:nvidia-driver-libs-410.72-1.el7.x86_64 (cuda)

           Requires: libglvnd(x86-64) >= 0.2

 You could try using --skip-broken to work around the problem

 You could try running: rpm -Va --nofiles --nodigest






<resolve>

https://rpmfind.net 에서 해당 패키지 rpm 을 찾아서 yum 으로 설치 한 후 해결 되었습니다. 


http://rpmfind.net/linux/epel/6/x86_64/Packages/l/libglvnd-1.0.1-0.1.git5baa1e5.el6.x86_64.rpm

http://rpmfind.net/linux/epel/6/x86_64/Packages/l/libglvnd-gles-1.0.1-0.1.git5baa1e5.el6.x86_64.rpm

http://rpmfind.net/linux/epel/6/x86_64/Packages/l/libglvnd-egl-1.0.1-0.1.git5baa1e5.el6.x86_64.rpm

http://rpmfind.net/linux/epel/6/x86_64/Packages/l/libglvnd-opengl-1.0.1-0.1.git5baa1e5.el6.x86_64.rpm

http://rpmfind.net/linux/epel/6/x86_64/Packages/l/libglvnd-glx-1.0.1-0.1.git5baa1e5.el6.x86_64.rpm


yum -y install  http://rpmfind.net......



Posted by CheekyKite

댓글을 달아 주세요