지식공유2017. 3. 14. 10:03

[Resolved] Two Cisco Ethernet Switch uplinks with different speeds via SFP and SFP+

(Cisco Nexus 3524 -10GbE and Catalyst 3750G-24TS-24 - 1GbE)


issue :  Cisco 호환 모듈 2개를 준비하여 각 스위치 의 SFP & SFP+ 포트에 장착 하고

Direct 광 점퍼케이블 을 연결 하였으나 두 스위치가 연결되지 않음 (링크 표시등 켜지지 않음)

10GbE 쪽 모듈에서는 붉은 불빛이 확인 되었으나 (모듈 인식 됨)

1GbE 쪽 모듈에서는 불빛이 확인되지 않음 (모듈 인식 안됨)








### 1GbE 스위치 Cisco Catalyst 3750G-24TS-24  설정 확인

### 모듈은 26번 포트에 연결 하였습니다.


1GbE-switch>

1GbE-switch>

1GbE-switch>en

Password:

1GbE-switch#

1GbE-switch#show running-config

Building configuration...


-- 생략 --


interface GigabitEthernet1/0/25

switchport trunk encapsulation dot1q

switchport mode access

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

!

interface GigabitEthernet1/0/26

!

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28


-- 생략 --


1GbE-switch#

1GbE-switch#show interfaces gigabitEthernet 1/0/26

GigabitEthernet1/0/26 is down, line protocol is down (err-disabled)

 Hardware is Gigabit Ethernet, address is 081f.f3d3.ea9a (bia 081f.f3d3.ea9a)

 MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

    reliability 255/255, txload 1/255, rxload 1/255

 Encapsulation ARPA, loopback not set

 Keepalive not set

 Auto-duplex, Auto-speed, link type is auto, media type is 1000BaseSX SFP

 input flow-control is off, output flow-control is unsupported


1GbE-switch#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

1GbE-switch(config)#interface gigabitEthernet 1/0/26

1GbE-switch(config-if)#

1GbE-switch(config-if)#shutdown

1GbE-switch(config-if)#

1GbE-switch(config-if)#no shutdown

15w5d: %LINK-5-CHANGED: Interface GigabitEthernet1/0/26, changed state to administratively down

15w5d: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/26, changed state to down

1GbE-switch(config-if)#exit

1GbE-switch(config)#do show int gi1/0/26

GigabitEthernet1/0/26 is down, line protocol is down (notconnect)

 Hardware is Gigabit Ethernet, address is 081f.f3d3.ea9a (bia 081f.f3d3.ea9a)

 MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

    reliability 255/255, txload 1/255, rxload 1/255

 Encapsulation ARPA, loopback not set

 Keepalive not set

 Auto-duplex, Auto-speed, link type is auto, media type is 1000BaseSX SFP

 input flow-control is off, output flow-control is unsupported


1GbE-switch(config)#


### 26번에서 27번 포트로 옮겨 보았습니다.


1GbE-switch(config)#

1GbE-switch(config)#

1GbE-switch(config)#do show int gi1/0/27

GigabitEthernet1/0/27 is down, line protocol is down (err-disabled)

 Hardware is Gigabit Ethernet, address is 081f.f3d3.ea9b (bia 081f.f3d3.ea9b)

 MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

    reliability 255/255, txload 1/255, rxload 1/255

 Encapsulation ARPA, loopback not set

 Keepalive not set

 Auto-duplex, Auto-speed, link type is auto, media type is Not Present

 input flow-control is off, output flow-control is unsupported


1GbE-switch(config)#

1GbE-switch(config)#interface gigabitEthernet 1/0/27

1GbE-switch(config-if)#

1GbE-switch(config-if)#shutdown

1GbE-switch(config-if)#

1GbE-switch(config-if)#no shutdown

1GbE-switch(config-if)#

15w5d: %LINK-5-CHANGED: Interface GigabitEthernet1/0/27, changed state to administratively downexit

1GbE-switch(config-if)#exit

15w5d: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/27, changed state to down

1GbE-switch(config)#

1GbE-switch(config)#do show int gi1/0/27

GigabitEthernet1/0/27 is down, line protocol is down (notconnect)

 Hardware is Gigabit Ethernet, address is 081f.f3d3.ea9b (bia 081f.f3d3.ea9b)

 MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

    reliability 255/255, txload 1/255, rxload 1/255

 Encapsulation ARPA, loopback not set

 Keepalive not set

 Auto-duplex, Auto-speed, link type is auto, media type is Not Present

 input flow-control is off, output flow-control is unsupported

 

### 포트 활성화 후 모듈은 인식 되었고, TX 포트에서 붉은 불빛이 확인 되었습니다.

### 하지만 링크에 표시등은 켜지지 않아 10GB 스위치 Nexus 3524 의 설정을 확인 하였습니다.

### 모듈은 Cisco Catalyst 3750G-24TS-24 와 동일하게 27번 포트에 연결 하였습니다.


10GbE-switch#

10GbE-switch# show interface brief


--------------------------------------------------------------------------------

Ethernet      VLAN   Type Mode   Status  Reason                   Speed     Port

Interface                                                                   Ch #

--------------------------------------------------------------------------------


-- 생략 --


Eth1/25       1       eth  access down    SFP not inserted            10G(D) --

Eth1/26       1       eth  access down    SFP not inserted            10G(D) --

Eth1/27       1       eth  access down    Link not connected          10G(D) --

Eth1/28       1       eth  access down    SFP not inserted            10G(D) --

Eth1/29       1       eth  access down    SFP not inserted            10G(D) --

Eth1/30       1       eth  access down    SFP not inserted            10G(D) --

Eth1/31       1       eth  access down    Link not connected          10G(D) --


-- 생략 --


10GbE-switch# configure t

Enter configuration commands, one per line.  End with CNTL/Z.

10GbE-switch(config)# interface ethernet 1/27

10GbE-switch(config-if)#

10GbE-switch(config-if)# speed ?

 10     10Mb/s

 100    100Mb/s

 1000   1Gb/s

 10000  10Gb/s

 40000  40Gb/s

 auto   Auto negotiate speed


10GbE-switch(config-if)#

10GbE-switch(config-if)# speed 1000

10GbE-switch(config-if)# exit

10GbE-switch(config)# exit

10GbE-switch# show interface brief


--------------------------------------------------------------------------------

Ethernet      VLAN   Type Mode   Status  Reason                   Speed     Port

Interface                                                                   Ch #

--------------------------------------------------------------------------------


-- 생략 --


Eth1/25       1       eth  access down    SFP not inserted            10G(D) --

Eth1/26       1       eth  access down    SFP not inserted            10G(D) --

Eth1/27       1       eth  access up      none                       1000(D) --

Eth1/28       1       eth  access down    SFP not inserted            10G(D) --

Eth1/29       1       eth  access down    SFP not inserted            10G(D) --

Eth1/30       1       eth  access down    SFP not inserted            10G(D) --

Eth1/31       1       eth  access down    Link not connected          10G(D) --


-- 생략 --


10GbE-switch#


### 포트 속도를 10G 에서 1000M 로 변경 후 링크 확인 되었습니다.

### 링크 된 후 화면은 캡쳐하지 못했네요 ^^;;

### 현재 설정을 rom에 꼭 저장하시기 바랍니다.


<끝>

Posted by CheekyKite
TAG

댓글을 달아 주세요